دستورات ccna سوییچ

خلاصه دستورات CCNA سوییچ

دوستان در این قسمت سعی شده تا خلاصه دستورات CCNA سوییچ برای دسترسی سریع جمع آوری شود. امیدواریم که برای استفاده شما مفید باشد.

شما هم میتوانید برای تکمیل و تصحیح خلاصه دستورات CCNA سوییچ به ما کمک کنید.

خلاصه دستورات CCNA سوییچ قسمت اول

پورت کنسول برای اتصال به دستگاه های سیسکو RS 232 هست.
در صورتی که خروجی یک دستور زیاد باشد با فشردن کلید اسپیس صفحه به صفحه و با فشردن کلید اینتر خط به خط نمایش داده میشود.
در زمان استفاده از دستورات CCNA سوییچ برای مشاهده تنظیمات از کامند show استفاده میشود.
برای انجام تنظیمات باید وارد محیط کانفیگور ترمینال یا همان گلوبال مد شد.
برای تنظیم نام دستگاه ابتدا عبارت hostname و در جلوی آن نام مورد نظر را تایپ میکنیم.
کامند banner زمانی که کاربری به دستگاه لاگین کند پیامی را به کاربر نمایش خواهد داد.
کار با آن به صورت زیر است: در دستور زیر motd مخفف massege of today است

banner motd #welcome to here#

برای تنظیم تایم زون به صورت زیر عمل میکنیم

Clock timezone Teh 03 30

برای تنظیم ساعت در اینیبل مد به صورت زیر عمل میکنیم

clock set 15:12:12 3 Mar 2022

برای تنظیم تایم سرور به صورت زیر عمل میکنیم


ntp server 192.168.2.12 prefer
ntp server 192.168.2.14


برای تغییر زمان پیش فرض سینک شدن با تایم سرور که هر 60 ثانیه هست به صورت

ntp clock-period 120


و برای مشاهده وضعیت تایم سرور به صورت زیر عمل میکنیم:

show ntp {association | status}

وقتی در محیط کانفیگ ترمینال دستوری را اشتباه تایپ میکنیم برای جلوگیری از اتلاف وقت میتوان از کلید های ترکیبی
Ctrl+shift+6 استفاده کرد.
با تایپ دستور end یا exit از محیط کانفیگور ترمینال خارج شده و وارد محیط enable مود میشویم.
در محیط کانفیگور ترمینال با تایپ دستور enable password یا enable secret میتوان برای ورود به حالت enable پسورد تنظیم کنیم. در محیط کانفیگور ترمینال تایپ دستور

service password-encryption

باعث میشود تمام پسوردهای موجود در دستگاه رمزگذاری شود. اولویت کامند enable secret نسبت به enable password بالاتر است. یعنی اگر هردوی این کامندها روی دستگاه ست شده باشد در زمان ورود باید پسورد enable secret را وارد کنید. برای ورود به تنظیمات پورت کنسول در محیط کانفیگور ترمینال نام پورت کنسول را مانند زیر وارد میکنیم:

line console 0

سپس میتوان مانند بالا برای این پورت هم پسورد ست کرد. برای مشاهده تنظیمات هم در محیط enable از دستور
show run میتوان استفاده کرد.

برای استفاده از دستورات enable مود در محیط کانفیگ در ابتدای آن دستور do را تایپ میکنیم. برای مشاهده وضعیت اینترفیس ها از دستور

show run

یا

show interfaces

استفاده میکنیم. همچنین میتوان برای مشاهده خلاصه ای از وضعیت اینترفیس از دو دستور زیر استفاده کرد.


show ip interface brief
show interfaces status

برای انجام تنظیمات روی یک اینترفیس در محیط کانفیگور ترمینال، نام اینترفیس مورد نظر را به صورت تایپ میکنیم.

interface vlan 1

با دستور زیر میتوان اینترفیس مورد نظر را در حالت روشن قرار داد.

no shutdown

برای اختصاص آی پی به این اینترفیس به صورت زیر عمل میکنیم:

ip address 192.168.2.2 255.255.255.0

برای نوشتن توضیح برای اینترفیس از کامند description به صورت زیر استفاده میشود:

description vasle be server

برای انجام یک تنظیم بر روی چند اینترفیس از دستور رنج به صورت زیر برای انتخاب آنها استفاده میشود:

interface range gigabitethernet 0/0 -10

بعد از تایپ دستور بالا و انتخاب اینترفیس ها میتوان دستورات لازم را تایپ کرد. توجه داشته باشید امکان اختصاص آی پی به اینترفیسها در این حالت وجود ندارد.
با توجه به اینکه سوییچها در لایه 2 فعالیت میکنند و فقط مک آدرس را شناسایی میکنند، برای تنظیم آی پی روی سوییچ ها در ابتدا باید به اینترفیس vlan 1 آنها آی پی داده شود یا یک ویلن دیگر ساخته و به آن آی پی اختصاص داد.

برای اختصاص آی پی به ویلین پس از انتخاب آن، ابتدا آنرا در حالت no shutdown قرار داده و سپس یک آی پی در رنج شبکه داخلی به آن میدهیم.

برای راه اندازی تلنت روی دستگاه ابتدا یک سکرت پسورد روی دستگاه تنظیم میکنیم در صورت انجام ندادن این کار بعد از اتصال از طریق تلنت امکان ورود به enable مود نخواهد بود.

برای راه اندازی سرویس تلنت باید از با دستور line vty سپس عددی بین 0 تا 15 استفاده کرد. کاربرد اعداد در این دستور برای تعیین تعداد کانکشن ها از طریق تلنت یا ssh میباشد. به صورت زیر

line vty 0 4

سپس وارد محیط config-line میشوید که با تایپ دستور

password 2744

پسوردی برای سرویس تلنت خود انتخاب میکنیم که در اینجا 2744 پسورد است. در این حالت سرویس تلنت به صورت پیشفرض انتخاب شده است اما رو دستگاه فعال نیست. برای فعال کردن آن دستور لاگین را وارد میکنیم.

login

برای ایجاد ارتباط از طریق ssh باید دستور زیر را وارد کرد

transport input ssh

در صورت تمایل به استفاده از هر دو پروتکل هم میتوان از دستور زیر استفاده کرد.

transport input all

برای جلوگیری از اتصال به صورت تلنت و ssh هم دستور زیر را وارد میکنیم.

transport input none

در اینجا برای خروج لازم هست که دستور exitبه صورت کامل تایپ شود.
برای ایجاد یوزرنیم و پسورد در مد کانفیگور به صورت زیر عمل میکنیم:

username hossein secret mh

پیش نیازهای راه اندازی ssh در دستگاه های سیسکو

همون طور میدانید یکی از راه های ارتباطی با دستگاه برای اجرای دستورات CCNA سوییچ استفاده از ssh میباشد که استفاده از آن نیازمند اجرای کارهای گفته شده در زیر می باشد:

1.اختصاص hostname به دستگاه
2.اختصاس enable secret به دستگاه
3. تنظیم آی پی برای interface vlan1
4. تایپ دستور no shut interface روی اینترفیس ویلین
5.set username & secret
6. تعین line vty 0 4
7. تایپ دستور transport input ssh
8. تایپ دستور login local
9. تنظیم نام دامین با دستور ip domain-name lanmaster
10. تایپ دستور crypto key generate rsa و در خط بعد تایپ عددی بین 512 تا 1024

برای استفاده از امکانات بیشتر در ssh در زمان تایپ دستورات دستورات CCNA سوییچ بهتر است از ورژن 2 ssh با دستور زیر استفاده کرد

ip ssh version 2

با این کار مثلا میتوان محدودیت برای تعداد دفعات اشتباه وارد کردن پسورد گذاشت. با دستور زیر

ip ssh authentication-retries 5

با دستور بالا اگر کاربر 5 بار پسورد را اشتباه وارد کند کانکشن بسته میشود. همچنین میتوان تنظیم کرد اگر ظرف 5 ثانیه پسورد وارد نشود کانکشن بسته شود. با دستور زیر

ip ssh time-out 5

با دستور exec-timeout در قسمت line vty 0 4 میتوانیم تنظیم کنیم که اگر کاربر هیچ کامندی را در محیط سوییچ وارد نکند از محیط آن خارج شود.

exec-timeout 1 30

با دستور بالا 90 ثانیه زمان برای تایپ دستورات وجود دارد.

آشنایی با فضاهای ذخیره سازی موجود روی دستگاه های سیسکو برای درک بهتر اجرای دستورات CCNA سوییچ

انواع حافظه های موجود بر روی دستگاه های سیسکو
RAM حافظه موقت است و بعد از رست شدن دستگاه تمام اطلاعات قبلی آن پاک خواهد شد و محیط runing config میباشد.
ROM برنامه بوت هلپر یا بوت استرپ در آن ذخیره میشود. این برنامه ایمیج مربوط به آی او اس دستگاه را پیدا کرده و آنرا در داخل RAM لود میکند.
FLASH فضایی هست که آی او اس در آن نگهداری میشود.
NVRAM عملکرد این حافظه شبیه هارد دیسک در کامپیوتر است و اطلاعات و تنظیمات انجام شده در حافظه RAM را میتوان برای ماندگاری در این حافظه ذخیره کرد. این فضا با عنوان startup config هم شناخته میشود.


مراحل بوت شدن دستگاه سیسکو
1. اجرای برنامه post که مخفف power on self test هست. که قسمتهای سخت افزاری را تست میکند.
2. اجرای برنامه بوت استرپ که آی او اس سیستم را پیدا میکند و اولین مکان مموری فلش هست در صورت پیدا نشدن به tftp مراجعه خواهد کرد و در صورت پیدا نشدن خودش یک مینی آی اواس در داخل rom لود خواهد کرد.
3. پیدا کردن ios سیسکو
4. لود ios بر روی دستگاه
5. پیدا کردن تنظیمات ذخیره شده در startup config
6. اجرای کانفیگهای لود شده بر روی ram

در زمان اجرای دستورات CCNA سوییچ در محیط enable مود میتوان با دستور reload دستگاه را راه اندازی دوباره کرد. برای ذخیره تغییرات انجام شده در محیط enable مود از دستور زیر استفاده میکنیم:

copy running-config startup-config

همچنین برای این کار میتوان از دستور write استفاده کرد.
برای حذف تنظیمات انجام شده هم میتوان از دستور زیر استفاده کرد:

erase startup-config

برای مشاهده آی او اس میتوان در محیط enable مود از دستور زیر استفاده کرد:

show version

dir flash یا show flash برای مشاهده اطلاعات کاملتر از آی او اس میتوان از دستور
.استفاده کرد

برودکست و کالیژن دامین

به ناحیه ای که در داخل آن پیام های برودکست به دیگر اعضا منتقل میشوند برودکست دامین گفته میشود.
کالیژن دامین به محدوده ای گفته میشود که در آن امکان وجود کالیژن وجود داشته باشد. که در سوییچ های سیسکو به ازای هر پورت یک کالیژن دامین وجود دارد و فقط بین پورت سوییچ و دستگاهی هست که به آن پورت متصل شده است.

کار با vlan در دستورات CCNA سوییچ

vlan ها در واقع سوییچ مجازی هست که محدوده ی برودکست دامین آن در داخل همان vlan هستند.
در زمان اجرای دستورات CCNA سوییچ برای ساخت vlan در محیط کانفیگور مد باید ابتدا دستور vlan و سپس یک شماره را تایپ کنیم مثلا

vlan 10

با این کار vlan 10 ساخته میشود و در مد config-vlan قرار میگیریم و میتوان vlan ساخته شده را کانفیگ کرد. مثلا برای اختصاص نام به آن به صورت

name Lanmaster


عمل میکنیم. برای پاک کردن این vlan هم میتوان به صورت no vlan 10 عمل کرد. برای مشاهده vlan های موجود میتوان در مد enable از دستور

show vlan


استفاده کرد. در صورتی که نامی را برای vlan ساخته شده تنظیم نکنیم نام آن به صورت vlan دو صفر و سپس ld آن vlan مشخص میشود.
دستگاه بعد از ساخت هر vlan در سوئیچ، به هر vlan یک SAID برای شناسایی آن اعطا میشود و زمانی که با این vlan کار دارد به همین SAID مراجعه میکند. برای مشاهده اطلاعات vlan به صورت خلاصه از دستور زیر استفاده میکنیم:

show vlan brief


برای مشاهده اطلاعات مربوط به یک vlan که در اینجا vlan 1 مد نظر ما است به صورت
show vlan id 1 عمل میکنیم. با استفاده از نام vlan هم میتوان اطلاعات آنرا مشاهده کرد به صورت

show vlan name Lanmaster


در استاندارد vlan ها، vlan شماره 1 و 1002 تا 1005 به صورت رزرو شده هستند. اطلاعات مربوط به استاندارد vlan ها در داخل یک فایل به نام vlan.dat ذخیره میشود که این فایل در داخل حافظه flash و در کنار آی او اس دستگاه قرار میگیرد.
برای قرار دادن اینترفیس در داخل یک vlan ابتدا اینترفیس مربوطه را انتخاب کرده و سپس آنرا در داخل vlan قرار میدهیم.
اینترفیس های سوئیچ های سیسکو میتوانند در سه مد access ،trunk و dynamic کار کنند.
در مد access اینترفیس فقط در یک vlan میتواند فعالیت کند. مد trunk برای انتقال اطلاعات vlanها از یک سوییچ به vlanهای دیگر در سوییچ دیگر استفاده میشود.
مد داینامیک دو حالت desireable و auto دارد که تمام پورتها در حالت پیشفرض در مد dynamic auto قرار دارند.
برای قرار دادن یک اینترفیس در یک vlan باید مد آنرا در حالت access قرار داد و آنرا عضو آن vlan کنیم. برای این کار بعد از انتخاب اینترفیس ابتدا دستور زیر را وارد میکنیم

switchport mode access


سپس دستور زیر را وارد میکنیم:

switch access vlan 2

در محیط کانفیگور ترمینال میتوان با دستور زیر یک رنج از اینترفیس ها را انتخاب کرد:

interface range gig 0/1 -5

بعد از تایپ دستور بالا میتوان با دستور زیر این رنج از اینترفیس ها را به یک vlan اختصاص داد:

switchport mode access
switchport access vlan 2

دستورات trunk در ccna سوییچ

برای ارتباط دو vlan در دو سوییچ مجزا باید پورت های ارتباطی بین دو سوییچ را در مد trunk قرار داد.
اگر پورتهای ارتباطی در مد access باشد فقط ترافیک ویلنی که پورتها در آن قرار دارند از آن عبور خواهد کرد و ترافیک ویلنهای دیگر از آن عبور نخواهد کرد.

مثلا برای ارتباط 3 ویلن مختلف در 2 سوییچ باید 3 کابل ارتباطی که هر کدام در یک ویلن و در مد اکسس باشند را باید در آنها قرار داد.
ترانک از دو پروتکل 802.1Q و ISL استفاده میکند. که ISL مخصوص دستگاه های سیسکو هست اما در دستگاه های جدید فقط از پروتکل 802.1Q استفاده میشود.
قبل از ست اینترفیس رابط بین دو سوییچ در مد ترانک باید نوع پروتکل انکپسولیشت را با دستور زیر مشخص نمود

switchport trunk encapsulation dot1q


سپس باید دستور زیر را وارد کرد:

switchport mode trunk


بهتر است اینکار در هر دو سمت انجام شود البته در صورت انجام در یک سمت هم ممکن است ارتباط برقرار شود.
برای مشاهده اینترفیسهای ترانک از دستور زیر استفاده میشود

show interface trunk

برای مشاهده وضعیت یک پورت خاص به صورت زیر عمل میکنیم:

show interface gig 0/1 switchport

پروتکل dtp مخفف dynamic trunking protocol است و برای اعمال و ایجاد اینترفیس های ترانک به صورت پویا و داینامیک مورد استفاده قرار میگیرد و محصول شرکت سیسکو میباشد.
این پروتکل به صورت پیشفرض فعال میباشد. این پروتکل در دو مد داینامیک Auto و داینامیک دیزایربل فعالیت میکند.
اگر اینترفیس را در حالت داینامیک دیزایربل ست کنیم در این حالت این اینترفیس شروع کننده ترانک هست و به سمت مقابل پیشنهاد ترانک کردن اینترفیس را میدهد اما اگر اینترفیس در حالت داینامیک Auto باشد منتظر رسیدن درخواست از سمت مقابل خواهد ماند.
اگر هر دو سمت در حالت دیزایربل ست باشد باز هم ارتباط برقرار خواهد شد اما اگر هردو طرف در مد auto تنظیم شده باشند ارتباط برقرار نخواهد شد.
اگر یک سمت ترانک و در سمت مقابل دیزایربل باشد ارتباط برقرار میشود اما اگر یک سمت دیزایربل و سمت دیگر اکسس باشد ارتباط برقرار نخواهد شد.
در بسیاری از سوئیچ ها انکپسولیشن مربوط به اینترفیسها به صورت پیشفرض در مد dot1q قرار دارد و نیازی به وارد کردن دستور مربوطه نیست.
در بعضی از سازمانها پروتکل dtp راغیرفعال میکنند که برای این کار در سوئیچ، اینترفیس ترانک را انتخاب کرده و سپس از دستور زیر استفاده میکنیم

switchport nonegotiate

این کار را در زمانی که پورت در حالت داینامیک قرار دارد نمیتوان انجام داد و باید ابتدا آنرا در حالت ترانک قرار دارد.

برای مجاز یا غیر مجاز کردن عبور ترافیک ویلن از دستور ترنک allowed استفاده میشود.
برای این کار ابتدا اینترفیس ترانک را انتخاب کرده سپس دستور زیر را برای مشخص کردن ترانک مجاز وارد میکنیم:

switchport trunk allowed vlan 1

این کار را در هر دو سمت کانکشن انجام میدهیم. برای اضافه کردن یک ویلن به لیست مجاز میتوان به صورت زیر هم عمل کرد:

switchport trunk allowed vlan add 3

با این کار ویلن 3 هم به لیست مجاز عبور ترافیک اضافه میشود. این کار را در هر دو سمت باید وارد کرد. برای حذف یک ویلن از لیست مجاز به صورت زیر عمل میکنیم:

switchport trunk allowed vlan remove 2

شما هم میتوانید برای تکمیل خلاصه دستورات CCNA سوییچ به ما کمک کنید.

دیدگاه‌ خود را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.